<!DOCTYPE html>
<html dir='ltr' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<meta content='width=device-width, initial-scale=1' name='viewport'/>
<meta content='$ilp.uphold.com/FYbQjxZy6hrM' name='monetization'/>
<title>Firefox 89 on POWER</title>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='#01050c' name='theme-color'/>
<!-- Windows Phone -->
<meta content='#01050c' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.talospace.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.talospace.com/2021/06/firefox-89-on-power.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Talospace - Atom" href="https://www.talospace.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Talospace - RSS" href="https://www.talospace.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Talospace - Atom" href="https://www.blogger.com/feeds/1196390459016343329/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Talospace - Atom" href="https://www.talospace.com/feeds/6339538028901117250/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-VJpmI6HJ8o8/YL6KIIhptMI/AAAAAAAACRQ/yZOolLVc4tQGcd5UbDdiyPuidvBjw8s2gCLcBGAsYHQ/s320/Screenshot%2Bfrom%2B2021-06-07%2B14-04-28.png' rel='image_src'/>
<meta content='https://www.talospace.com/2021/06/firefox-89-on-power.html' property='og:url'/>
<meta content='Firefox 89 on POWER' property='og:title'/>
<meta content='  Firefox 89 was released last week with much fanfare over its new interface , though being the curmudgeon I am I&#39;m less enamoured of it. I ...' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-VJpmI6HJ8o8/YL6KIIhptMI/AAAAAAAACRQ/yZOolLVc4tQGcd5UbDdiyPuidvBjw8s2gCLcBGAsYHQ/w1200-h630-p-k-no-nu/Screenshot%2Bfrom%2B2021-06-07%2B14-04-28.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<style type='text/css'>@font-face{font-family:'EB Garamond';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/ebgaramond/v15/SlGDmQSNjdsmc35JDF1K5E55YMjF_7DPuGi-6_RkBI96.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:300;src:url(//fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh7USSwiPHA.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/lato/v17/S6uyw4BMUTPHjx4wWw.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:700;src:url(//fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh6UVSwiPHA.ttf)format('truetype');}@font-face{font-family:'Lora';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/lora/v17/0QI6MX1D_JOuGQbT0gvTJPa787weuxJBkqg.ttf)format('truetype');}@font-face{font-family:'Montserrat';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/montserrat/v15/JTUSjIg1_i6t8kCHKm459Wlhzg.ttf)format('truetype');}@font-face{font-family:'Montserrat';font-style:normal;font-weight:700;src:url(//fonts.gstatic.com/s/montserrat/v15/JTURjIg1_i6t8kCHKm45_dJE3gnD-w.ttf)format('truetype');}</style>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
body#layout .hidden,
body#layout .invisible {
display: inherit;
}
body#layout .page {
width: 60%;
}
body#layout.ltr .page {
float: right;
}
body#layout.rtl .page {
float: left;
}
body#layout .sidebar-container {
width: 40%;
}
body#layout.ltr .sidebar-container {
float: left;
}
body#layout.rtl .sidebar-container {
float: right;
}
--></style>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/imagesloaded/imagesloaded-3.1.8.min.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/vanillamasonry-v3_1_5/masonry.pkgd.min.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/clipboardjs/clipboard.min.js'></script>
<style>
    body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/s1600\/talospacebg.jpg);}
    
@media (max-width: 320px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w320\/talospacebg.jpg);}}
@media (max-width: 640px) and (min-width: 321px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w640\/talospacebg.jpg);}}
@media (max-width: 800px) and (min-width: 641px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w800\/talospacebg.jpg);}}
@media (max-width: 1024px) and (min-width: 801px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1024\/talospacebg.jpg);}}
@media (max-width: 1440px) and (min-width: 1025px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1440\/talospacebg.jpg);}}
@media (max-width: 1680px) and (min-width: 1441px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1680\/talospacebg.jpg);}}
@media (max-width: 1920px) and (min-width: 1681px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1920\/talospacebg.jpg);}}
/* Last tag covers anything over one higher than the previous max-size cap. */
@media (min-width: 1921px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w2560\/talospacebg.jpg);}}
  </style>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=1196390459016343329&amp;zx=3add80db-41b9-4d3f-8c49-73404ad017ec' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=1196390459016343329&amp;zx=3add80db-41b9-4d3f-8c49-73404ad017ec' rel='stylesheet'/></noscript>

<!-- data-ad-client=ca-pub-5054520162605658 -->

</head>
<body class='post-view item-view version-1-3-0'>
<a class='skip-navigation' href='#main' tabindex='0'>
Skip to main content
</a>
<div class='page'>
<div class='page_body'>
<div class='main-page-body-content'>
<div class='centered-top-placeholder'></div>
<header class='centered-top-container' role='banner'>
<div class='centered-top'>
<div class='back-button-container'>
<a href='https://www.talospace.com/'>
<svg class='svg-icon-24 touch-icon back-button rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</a>
</div>
<div class='search'>
<button aria-label='Search' class='search-expand touch-icon-button'>
<div class='search-expand-text'>Search</div>
<svg class='svg-icon-24 touch-icon search-expand-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
<div class='section' id='search_top' name='Search (Top)'><div class='widget BlogSearch' data-version='2' id='BlogSearch1'>
<h3 class='title'>
Search This Blog
</h3>
<div class='widget-content' role='search'>
<form action='https://www.talospace.com/search' target='_top'>
<div class='search-input'>
<input aria-label='Search this blog' autocomplete='off' name='q' placeholder='Search this blog' value=''/>
</div>
<label>
<input type='submit'/>
<svg class='svg-icon-24 touch-icon search-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</label>
</form>
</div>
</div></div>
</div>
<div class='blog-name'>
<div class='section' id='header' name='Header'><div class='widget Header' data-version='2' id='Header1'>
<div class='header-widget'>
<div>
<h1>
<a href='https://www.talospace.com/'>
Talospace
</a>
</h1>
</div>
<p>
The free computing frontier
</p>
</div>
</div></div>
<nav role='navigation'>
<div class='no-items section' id='page_list_top' name='Page List (Top)'>
</div>
</nav>
</div>
</div>
</header>
<div class='hero-image has-image'>
</div>
<main class='centered-bottom' id='main' role='main' tabindex='-1'>
<div class='main section' id='page_body' name='Page Body'>
<div class='widget Blog' data-version='2' id='Blog1'>
<div class='blog-posts hfeed container'>
<div class='post-outer-container'>
<div class='post-outer'>
<div class='post-sidebar'>
<div class='post-sidebar-item post-share-buttons'>
<div aria-owns='sharing-popup-Blog1-byline-6339538028901117250' class='sharing' data-title=''>
<button aria-controls='sharing-popup-Blog1-byline-6339538028901117250' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-6339538028901117250' role='button'>
Share
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-6339538028901117250' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=facebook' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=twitter' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=pinterest' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=email' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
<div class='post-sidebar-item post-sidebar-labels'>
<div>Labels</div>
<ul>
<li><a href='https://www.talospace.com/search/label/Firefox' rel='tag'>Firefox</a></li>
<li><a href='https://www.talospace.com/search/label/Software' rel='tag'>Software</a></li>
</ul>
</div>
</div>
<div class='post'>
<script type='application/ld+json'>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.talospace.com/2021/06/firefox-89-on-power.html"
  },
  "headline": "Firefox 89 on POWER","description": "Firefox 89 was released last week with much fanfare over its new interface , though being the curmudgeon I am I\u0026#39;m less enamoured of it...","datePublished": "2021-06-07T18:37:00-07:00",
  "dateModified": "2021-06-07T18:37:11-07:00","image": {
    "@type": "ImageObject","url": "https://1.bp.blogspot.com/-VJpmI6HJ8o8/YL6KIIhptMI/AAAAAAAACRQ/yZOolLVc4tQGcd5UbDdiyPuidvBjw8s2gCLcBGAsYHQ/w1200-h630-p-k-no-nu/Screenshot%2Bfrom%2B2021-06-07%2B14-04-28.png",
    "height": 630,
    "width": 1200},"publisher": {
    "@type": "Organization",
    "name": "Blogger",
    "logo": {
      "@type": "ImageObject",
      "url": "https://lh3.googleusercontent.com/ULB6iBuCeTVvSjjjU1A-O8e9ZpVba6uvyhtiWRti_rBAs9yMYOFBujxriJRZ-A=h60",
      "width": 206,
      "height": 60
    }
  },"author": {
    "@type": "Person",
    "name": "ClassicHasClass"
  }
}</script>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-author vcard'>
<span class='post-author-label'>
Posted by
</span>
<span class='fn'>
<meta content='https://www.blogger.com/profile/17331846076856918359'/>
<a class='g-profile' href='https://www.blogger.com/profile/17331846076856918359' rel='author' title='author profile'>
<span>ClassicHasClass</span>
</a>
</span>
</span>
<span class='byline post-timestamp'>
on
<meta content='https://www.talospace.com/2021/06/firefox-89-on-power.html'/>
<a class='timestamp-link' href='https://www.talospace.com/2021/06/firefox-89-on-power.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2021-06-07T18:37:00-07:00' title='2021-06-07T18:37:00-07:00'>
June 07, 2021
</time>
</a>
</span>
<span class='byline post-labels'>
<span class='byline-label'>Labels:</span>
<a href='https://www.talospace.com/search/label/Firefox' rel='tag'>Firefox</a>
<a href='https://www.talospace.com/search/label/Software' rel='tag'>Software</a>
</span>
</div>
</div>
<a name='6339538028901117250'></a>
<h3 class='post-title entry-title'>
Firefox 89 on POWER
</h3>
<br/>
<div class='post-body-container'>
<div class='post-body entry-content float-container' id='post-body-6339538028901117250'>
<div class="separator" style="clear: both;"><a href="https://1.bp.blogspot.com/-VJpmI6HJ8o8/YL6KIIhptMI/AAAAAAAACRQ/yZOolLVc4tQGcd5UbDdiyPuidvBjw8s2gCLcBGAsYHQ/s1100/Screenshot%2Bfrom%2B2021-06-07%2B14-04-28.png" style="display: block; padding: 1em 0; text-align: center; "><img alt="" border="0" data-original-height="151" data-original-width="1100" src="https://1.bp.blogspot.com/-VJpmI6HJ8o8/YL6KIIhptMI/AAAAAAAACRQ/yZOolLVc4tQGcd5UbDdiyPuidvBjw8s2gCLcBGAsYHQ/s320/Screenshot%2Bfrom%2B2021-06-07%2B14-04-28.png" width="320"/></a></div>
<p>
Firefox 89 was released last week with <a href="https://www.mozilla.org/en-US/firefox/89.0/releasenotes/">much fanfare over its new interface</a>, though being the curmudgeon I am I'm less enamoured of it. I like the improvements to menus and doorhangers but I'm a big user of compact tabs, <a href="https://www.ghacks.net/2021/04/07/mozilla-decides-to-hide-compact-mode-in-firefox-for-new-users-but-keep-it-for-existing-ones/">which were deprecated</a>, and even with compact mode surreptitously enabled the tab bar is still about a third or so bigger than Firefox 88 (see screenshot). There do seem to be some other performance improvements, though, plus the usual <a href="https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/89">more lower-level changes</a> and WebRender is now on by default for all Linux configurations, including for you fools out there trying to run Nvidia GPUs.
<p>
The chief problem is that Fx89 may not compile correctly with certain versions of <tt>gcc</tt> 11 (see bugs <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1710235">1710235</a> and <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1713968">1713968</a>). For Fedora users if you aren't on <tt>11.1.1-3</tt> (the current version as of this writing) you won't be able to compile the browser at all, and you may not be able to compile it fully even then without putting a <tt>#  pragma GCC diagnostic ignored "-Wnonnull"</tt> at the top of <tt>js/src/builtin/streams/PipeToState.cpp</tt> (I still can't; see <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1713968">bug 1713968</a>). <tt>gcc</tt> 10 is unaffected. I used the same <tt>.mozconfig</tt>s and PGO-LTO optimization patches as <a href="/2021/04/firefox-88-on-power.html">we used for Firefox 88</a>. With those changes the browser runs well.
<p>
While waiting for the updated <tt>gcc</tt> I decided to see if <tt>clang/clang++</tt> could now build the browser completely on <tt>ppc64le</tt> (it couldn't before), even though <tt>gcc</tt> remains my preferred compiler as it generates higher performance objects. The answer is now it can and this time it did, merely by substituting <tt>clang</tt> for <tt>gcc</tt> in the <tt>.mozconfig</tt>, but even using the <tt>bfd</tt> linker it makes a defective Firefox that freezes or crashes outright on startup; it could not proceed to the second phase of PGO-LTO and the build system aborted with an opaque error -139. So much for that. For the time being I think I'd rather spend my free cycles on <a href="/2021/06/progress-on-openpower-spidermonkey-jit.html">the OpenPOWER JavaScript JIT</a> than figuring out why <tt>clang</tt> still sucks at this.
<p>
Some of you will also have noticed the Mac-style pulldown menus in the screenshot, even though this Talos II is running Fedora 34. This comes from <a href="https://aur.archlinux.org/packages/firefox-appmenu/"><tt>firefox-appmenu</tt></a>, which since I build from source is trivial to patch in, and the <a href="https://github.com/gonzaarcr/Fildem">Fildem global menu GNOME extension</a> (<a href="https://www.linuxuprising.com/2021/02/how-to-install-fildem-global-menu-and.html">additional tips</a>) paired with my own custom <tt>gnome-shell</tt> theme. I don't relish adding another GNOME extension that Fedora 35 is certain to break, but it's kind of nice to engage my Mac mouse-le memory and it also gives me a little extra vertical room. You'll notice the window also lacks client-side decorations since I can just close the window with key combinations; this gives me a little extra horizontal tab room too. If you want that, <em>don't apply</em> <a href="https://aur.archlinux.org/cgit/aur.git/tree/fix_csd_window_buttons.patch?h=firefox-appmenu">this particular patch</a> from the <tt>firefox-appmenu</tt> series and just use the other two <tt>.patch</tt>es.
</div>
</div>
<div class='post-footer'>
<div class='post-footer-line post-footer-line-1'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-footer-1-6339538028901117250' class='sharing' data-title='Firefox 89 on POWER'>
<button aria-controls='sharing-popup-Blog1-footer-1-6339538028901117250' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-footer-1-6339538028901117250' role='button'>
Share
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-footer-1-6339538028901117250' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=facebook' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=twitter' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=pinterest' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=6339538028901117250&target=email' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.talospace.com/2021/06/firefox-89-on-power.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
<span class='byline'>
<a class='flat-button' href='https://www.blogger.com/email-post.g?blogID=1196390459016343329&postID=6339538028901117250'>Email Post</a>
</span>
</div>
</div>
</div>
</div>
<section class='comments embed' data-num-comments='0' id='comments'>
<a name='comments'></a>
<h3 class='title'>Comments</h3>
<div id='Blog1_comments-block-wrapper'>
</div>
<div class='footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<h4 id='comment-post-message'>Post a Comment</h4>
<p>Comments are subject to moderation. Be nice.</p>
<a href='https://www.blogger.com/comment-iframe.g?blogID=1196390459016343329&postID=6339538028901117250&skin=soho' id='comment-editor-src'></a>
<iframe allowtransparency='allowtransparency' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='410px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<script src='https://www.blogger.com/static/v1/jsbin/1114208092-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</div>
</section>
<div class='inline-ad'>
<ins class='adsbygoogle' data-ad-client='ca-pub-5054520162605658' data-ad-format='auto' data-ad-host='ca-host-pub-1556223355139109' data-analytics-uacct='' style='/* Done in css. */'></ins>
<script>
   (adsbygoogle = window.adsbygoogle || []).push({});
  </script>
</div>
</div>
</div>
</div>
</div>
</main>
</div>
<footer class='footer section' id='footer' name='Footer'><div class='widget Attribution' data-version='2' id='Attribution1'>
<div class='widget-content'>
<div class='blogger'>
<a href='https://www.blogger.com' rel='nofollow'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_post_blogger_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
Powered by Blogger
</a>
</div>
<div class='copyright'>Posts are the intellectual property of the original author and are under CC BY-SA 4.0.</div>
</div>
</div></footer>
</div>
</div>
<aside class='sidebar-container container sidebar-invisible' role='complementary'>
<div class='navigation'>
<svg class='svg-icon-24 touch-icon sidebar-back rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
<div class='section' id='sidebar' name='Sidebar'><div class='widget Label' data-version='2' id='Label1'>
<details class='collapsible extendable'>
<summary>
<div class='collapsible-title'>
<h3 class='title'>
Categories
</h3>
<svg class='svg-icon-24 chevron-down'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_more_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<svg class='svg-icon-24 chevron-up'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_less_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</summary>
<div class='widget-content list-label-widget-content'>
<div class='first-items'>
<ul>
<li><a class='label-name' href='https://www.talospace.com/search/label/Administrivia'>Administrivia<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Bare%20Metal'>Bare Metal<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/BSD'>BSD<span class='label-count'>7</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Distros'>Distros<span class='label-count'>66</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Firefox'>Firefox<span class='label-count'>33</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/First%20Person'>First Person<span class='label-count'>43</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Games'>Games<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Greatest%20Hits'>Greatest Hits<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Hacks'>Hacks<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Hardware'>Hardware<span class='label-count'>64</span></a></li>
</ul>
</div>
<div class='remaining-items'>
<ul>
<li><a class='label-name' href='https://www.talospace.com/search/label/History'>History<span class='label-count'>4</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/KVM'>KVM<span class='label-count'>11</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Microwatt'>Microwatt<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/News'>News<span class='label-count'>126</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Protips'>Protips<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Reviews'>Reviews<span class='label-count'>5</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Security'>Security<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Show%20Us%20Your%20Talos'>Show Us Your Talos<span class='label-count'>5</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Software'>Software<span class='label-count'>18</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Wall%20of%20Shame%20Dept.'>Wall of Shame Dept.<span class='label-count'>6</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/WTF%20Dept.'>WTF Dept.<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/YourHeadAsplode'>YourHeadAsplode<span class='label-count'>1</span></a></li>
</ul>
</div>
<span class='show-more flat-button'>Show more</span>
<span class='show-less hidden flat-button'>Show less</span>
</div>
</details>
</div><div class='widget BlogArchive' data-version='2' id='BlogArchive1'>
<details class='collapsible extendable'>
<summary>
<div class='collapsible-title'>
<h3 class='title'>
Past Posts
</h3>
<svg class='svg-icon-24 chevron-down'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_more_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<svg class='svg-icon-24 chevron-up'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_less_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</summary>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive1_ArchiveList'>
<div class='first-items'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/'>
2021
<span class='post-count'>30</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/06/'>
June
<span class='post-count'>2</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='posts hierarchy'>
<li>
<a href='https://www.talospace.com/2021/06/firefox-89-on-power.html'>Firefox 89 on POWER</a>
</li>
<li>
<a href='https://www.talospace.com/2021/06/progress-on-openpower-spidermonkey-jit.html'>Progress on the OpenPOWER SpiderMonkey JIT</a>
</li>
</ul>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/05/'>
May
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/04/'>
April
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/03/'>
March
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/02/'>
February
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2021/01/'>
January
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
</ul>
</div>
<div class='remaining-items'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/'>
2020
<span class='post-count'>69</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/12/'>
December
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/11/'>
November
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/10/'>
October
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/09/'>
September
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/08/'>
August
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/07/'>
July
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/06/'>
June
<span class='post-count'>9</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/05/'>
May
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/04/'>
April
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/03/'>
March
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/02/'>
February
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/01/'>
January
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/'>
2019
<span class='post-count'>82</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/12/'>
December
<span class='post-count'>3</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/11/'>
November
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/10/'>
October
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/09/'>
September
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/08/'>
August
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/07/'>
July
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/06/'>
June
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/05/'>
May
<span class='post-count'>10</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/04/'>
April
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/03/'>
March
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/02/'>
February
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/01/'>
January
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/'>
2018
<span class='post-count'>50</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/12/'>
December
<span class='post-count'>9</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/11/'>
November
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/10/'>
October
<span class='post-count'>10</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/09/'>
September
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/08/'>
August
<span class='post-count'>15</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/07/'>
July
<span class='post-count'>2</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
</ul>
</div>
<span class='show-more flat-button'>Show more</span>
<span class='show-less hidden flat-button'>Show less</span>
</div>
</div>
</div>
</details>
</div><div class='widget HTML' data-version='2' id='HTML1'>
<h3 class='title'>
About Talospace
</h3>
<div class='widget-content'>
Talospace is a blog and news site <a href="/2018/07/welcome-to-talospace.html">primarily focusing</a> on OpenPOWER and the Raptor Talos series of computers along with modern Power ISA and historical PowerPC topics generally. Talospace is sponsored by <a href="https://www.floodgap.com/">Floodgap Systems</a>.
<p>
All articles remain the intellectual property of the original authors, and are distributable under Creative Commons CC BY-SA 4.0. Comments posted on articles are subject to moderation, and may be removed if spammy, unsolicited commercial advertising or otherwise abusive to authors or community members, in the administration's sole judgment.
<p>
Interested in writing for Talospace? Here's our <a href="/2018/07/write-for-talospace.html">author guidelines</a>.
<p>
Talospace collects no personally identifiable information from its members itself. Advertising proceeds are strictly used to support the domain name and other costs of hosting Floodgap resources.
<p>
OpenPOWER&trade; is a trademark of the <a href="https://openpowerfoundation.org/">OpenPOWER Foundation</a>. Talos&trade;, Blackbird&trade;, Kestrel&trade; and Condor&trade; are trademarks of <a href="https://www.raptorcs.com/">Raptor Computing Systems</a> LLC. Neither Raptor CS LLC nor the OpenPOWER Foundation has any corporate connection to this blog nor endorses or supports it.
<p>
Editorial inquiries may be sent to <tt>talospace at floodgap dawt com</tt>.</p></p></p></p></p>
</div>
</div>
</div>
</aside>
<script type="text/javascript" src="https://resources.blogblog.com/blogblog/data/res/1459053738-fancy_compiled.js" async="true"></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/1147971663-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>