<!DOCTYPE html>
<html dir='ltr' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<meta content='width=device-width, initial-scale=1' name='viewport'/>
<meta content='$ilp.uphold.com/FYbQjxZy6hrM' name='monetization'/>
<title>Firefox 81 on POWER</title>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='#01050c' name='theme-color'/>
<!-- Windows Phone -->
<meta content='#01050c' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.talospace.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.talospace.com/2020/09/firefox-81-on-power.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Talospace - Atom" href="https://www.talospace.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Talospace - RSS" href="https://www.talospace.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Talospace - Atom" href="https://www.blogger.com/feeds/1196390459016343329/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Talospace - Atom" href="https://www.talospace.com/feeds/5134711199166894454/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<meta content='https://www.talospace.com/2020/09/firefox-81-on-power.html' property='og:url'/>
<meta content='Firefox 81 on POWER' property='og:title'/>
<meta content='Firefox 81 is released . In addition to new themes of dubious colour coordination, media controls now move to keyboards and supported headse...' property='og:description'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<style type='text/css'>@font-face{font-family:'EB Garamond';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/ebgaramond/v14/SlGDmQSNjdsmc35JDF1K5E55YMjF_7DPuGi-6_RkBI96.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:300;src:local('Lato Light'),local('Lato-Light'),url(//fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh7USSwiPHA.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:400;src:local('Lato Regular'),local('Lato-Regular'),url(//fonts.gstatic.com/s/lato/v17/S6uyw4BMUTPHjx4wWw.ttf)format('truetype');}@font-face{font-family:'Lato';font-style:normal;font-weight:700;src:local('Lato Bold'),local('Lato-Bold'),url(//fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh6UVSwiPHA.ttf)format('truetype');}@font-face{font-family:'Lora';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/lora/v16/0QI6MX1D_JOuGQbT0gvTJPa787weuxJBkqg.ttf)format('truetype');}@font-face{font-family:'Montserrat';font-style:normal;font-weight:400;src:local('Montserrat Regular'),local('Montserrat-Regular'),url(//fonts.gstatic.com/s/montserrat/v15/JTUSjIg1_i6t8kCHKm459Wlhzg.ttf)format('truetype');}@font-face{font-family:'Montserrat';font-style:normal;font-weight:700;src:local('Montserrat Bold'),local('Montserrat-Bold'),url(//fonts.gstatic.com/s/montserrat/v15/JTURjIg1_i6t8kCHKm45_dJE3gnD-w.ttf)format('truetype');}</style>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
body#layout .hidden,
body#layout .invisible {
display: inherit;
}
body#layout .page {
width: 60%;
}
body#layout.ltr .page {
float: right;
}
body#layout.rtl .page {
float: left;
}
body#layout .sidebar-container {
width: 40%;
}
body#layout.ltr .sidebar-container {
float: left;
}
body#layout.rtl .sidebar-container {
float: right;
}
--></style>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/imagesloaded/imagesloaded-3.1.8.min.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/vanillamasonry-v3_1_5/masonry.pkgd.min.js'></script>
<script async='async' src='https://www.gstatic.com/external_hosted/clipboardjs/clipboard.min.js'></script>
<style>
    body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/s1600\/talospacebg.jpg);}
    
@media (max-width: 320px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w320\/talospacebg.jpg);}}
@media (max-width: 640px) and (min-width: 321px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w640\/talospacebg.jpg);}}
@media (max-width: 800px) and (min-width: 641px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w800\/talospacebg.jpg);}}
@media (max-width: 1024px) and (min-width: 801px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1024\/talospacebg.jpg);}}
@media (max-width: 1440px) and (min-width: 1025px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1440\/talospacebg.jpg);}}
@media (max-width: 1680px) and (min-width: 1441px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1680\/talospacebg.jpg);}}
@media (max-width: 1920px) and (min-width: 1681px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w1920\/talospacebg.jpg);}}
/* Last tag covers anything over one higher than the previous max-size cap. */
@media (min-width: 1921px) { body.homepage-view .hero-image.has-image {background-image:url(\/\/1.bp.blogspot.com\/-Z6MXPUmg6YI\/Wz2GungnaCI\/AAAAAAAAApw\/sBGI-KBR7loqbl6w0lquhPpbiZwj5gy6wCK4BGAYYCw\/w2560\/talospacebg.jpg);}}
  </style>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=1196390459016343329&amp;zx=402c5382-3b8b-43df-bd1e-d33095e2285f' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=1196390459016343329&amp;zx=402c5382-3b8b-43df-bd1e-d33095e2285f' rel='stylesheet'/></noscript>

<!-- data-ad-client=ca-pub-5054520162605658 -->

</head>
<body class='post-view item-view version-1-3-0'>
<a class='skip-navigation' href='#main' tabindex='0'>
Skip to main content
</a>
<div class='page'>
<div class='page_body'>
<div class='main-page-body-content'>
<div class='centered-top-placeholder'></div>
<header class='centered-top-container' role='banner'>
<div class='centered-top'>
<div class='back-button-container'>
<a href='https://www.talospace.com/'>
<svg class='svg-icon-24 touch-icon back-button rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</a>
</div>
<div class='search'>
<button aria-label='Search' class='search-expand touch-icon-button'>
<div class='search-expand-text'>Search</div>
<svg class='svg-icon-24 touch-icon search-expand-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
<div class='section' id='search_top' name='Search (Top)'><div class='widget BlogSearch' data-version='2' id='BlogSearch1'>
<h3 class='title'>
Search This Blog
</h3>
<div class='widget-content' role='search'>
<form action='https://www.talospace.com/search' target='_top'>
<div class='search-input'>
<input aria-label='Search this blog' autocomplete='off' name='q' placeholder='Search this blog' value=''/>
</div>
<label>
<input type='submit'/>
<svg class='svg-icon-24 touch-icon search-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</label>
</form>
</div>
</div></div>
</div>
<div class='blog-name'>
<div class='section' id='header' name='Header'><div class='widget Header' data-version='2' id='Header1'>
<div class='header-widget'>
<div>
<h1>
<a href='https://www.talospace.com/'>
Talospace
</a>
</h1>
</div>
<p>
The free computing frontier
</p>
</div>
</div></div>
<nav role='navigation'>
<div class='no-items section' id='page_list_top' name='Page List (Top)'>
</div>
</nav>
</div>
</div>
</header>
<div class='hero-image has-image'>
</div>
<main class='centered-bottom' id='main' role='main' tabindex='-1'>
<div class='main section' id='page_body' name='Page Body'>
<div class='widget Blog' data-version='2' id='Blog1'>
<div class='blog-posts hfeed container'>
<div class='post-outer-container'>
<div class='post-outer'>
<div class='post-sidebar'>
<div class='post-sidebar-item post-share-buttons'>
<div aria-owns='sharing-popup-Blog1-byline-5134711199166894454' class='sharing' data-title=''>
<button aria-controls='sharing-popup-Blog1-byline-5134711199166894454' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-5134711199166894454' role='button'>
Share
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-5134711199166894454' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=facebook' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=twitter' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=pinterest' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=email' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
<div class='post-sidebar-item post-sidebar-labels'>
<div>Labels</div>
<ul>
<li><a href='https://www.talospace.com/search/label/Firefox' rel='tag'>Firefox</a></li>
</ul>
</div>
</div>
<div class='post'>
<script type='application/ld+json'>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.talospace.com/2020/09/firefox-81-on-power.html"
  },
  "headline": "Firefox 81 on POWER","description": "Firefox 81 is released . In addition to new themes of dubious colour coordination, media controls now move to keyboards and supported headsets, the bu&#8230;","datePublished": "2020-09-23T21:00:00-07:00",
  "dateModified": "2020-09-23T21:00:55-07:00","image": {
    "@type": "ImageObject","url": "https://lh3.googleusercontent.com/ULB6iBuCeTVvSjjjU1A-O8e9ZpVba6uvyhtiWRti_rBAs9yMYOFBujxriJRZ-A=w1200",
    "height": 348,
    "width": 1200},"publisher": {
    "@type": "Organization",
    "name": "Blogger",
    "logo": {
      "@type": "ImageObject",
      "url": "https://lh3.googleusercontent.com/ULB6iBuCeTVvSjjjU1A-O8e9ZpVba6uvyhtiWRti_rBAs9yMYOFBujxriJRZ-A=h60",
      "width": 206,
      "height": 60
    }
  },"author": {
    "@type": "Person",
    "name": "ClassicHasClass"
  }
}</script>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-author vcard'>
<span class='post-author-label'>
Posted by
</span>
<span class='fn'>
<meta content='https://www.blogger.com/profile/17331846076856918359'/>
<a class='g-profile' href='https://www.blogger.com/profile/17331846076856918359' rel='author' title='author profile'>
<span>ClassicHasClass</span>
</a>
</span>
</span>
<span class='byline post-timestamp'>
on
<meta content='https://www.talospace.com/2020/09/firefox-81-on-power.html'/>
<a class='timestamp-link' href='https://www.talospace.com/2020/09/firefox-81-on-power.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2020-09-23T21:00:00-07:00' title='2020-09-23T21:00:00-07:00'>
September 23, 2020
</time>
</a>
</span>
<span class='byline post-labels'>
<span class='byline-label'>Labels:</span>
<a href='https://www.talospace.com/search/label/Firefox' rel='tag'>Firefox</a>
</span>
</div>
</div>
<a name='5134711199166894454'></a>
<h3 class='post-title entry-title'>
Firefox 81 on POWER
</h3>
<br/>
<div class='post-body-container'>
<div class='post-body entry-content float-container' id='post-body-5134711199166894454'>
<a href="https://www.mozilla.org/en-US/firefox/81.0/releasenotes/">Firefox 81 is released</a>. In addition to new themes of dubious colour coordination, media controls now move to keyboards and supported headsets, the built-in JavaScript <a href="https://support.mozilla.org/kb/view-pdf-files-firefox-or-choose-another-viewer">PDF viewer now supports forms</a> (if we ever get a JIT going this will work a lot better), and there are <a href="https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/81">relatively few developer-relevant changes</a>.
<p>
This release heralds the first official change in our standard POWER9 <tt>.mozconfig</tt> since Fx67. Link-time optimization continues to work well (and in 81 the LTO-enhanced build I'm using now benches about 6% faster than standard <tt>-O3 -mcpu=power9</tt>), so I'm now making it a standard part of my regular builds with a minor tweak we have to make due to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1644409">bug 1644409</a>. Build time still about doubles on this dual-8 Talos II and it peaks out at almost 84% of its 64GB RAM during LTO, but the result is worth it.
<p>
Unfortunately PGO (profile-guided optimization) still doesn't work right, probably due to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1601903">bug 1601903</a>. The build system does appear to generate a profile properly, i.e., a controlled browser instance pops up, runs some JavaScript code, does some browser operations and so forth, and I see <tt>gcc</tt> created <tt>.gcda</tt> files with all the proper count information, but then the build system can't seem to find them to actually tune the executable. This needs a little more hacking which I might work on as I have free time&trade;. I'd also like to eliminate <tt>ac_add_options --disable-release</tt> as I suspect it is no longer necessary but I need to do some more thorough testing first.
<p>
In any event, reliable LTO at least with the current Fedora 32 toolchain is still continuous progress. I've heard concerns that some distributions are not making functional builds of Firefox for <tt>ppc64le</tt> (let alone <tt>ppc64</tt>, which has its own problems), though Fedora is not one of them. Still, if you have issues with your distribution's build and you are not able to build it for yourself, if there is interest I may put up a repo or a download spot for the binaries I use since I consider them reliable. Without further ado, here are the current <tt>.mozconfig</tt>s that I attest as functional.
<p>
<b>Optimized Configuration</b>
<pre>
export CC=/usr/bin/gcc
export CXX=/usr/bin/g++

mk_add_options MOZ_MAKE_FLAGS="-j24"
ac_add_options --enable-application=browser
ac_add_options --enable-optimize="-O3 -mcpu=power9"
ac_add_options --disable-release
ac_add_options --enable-linker=bfd
ac_add_options --enable-lto=full

#export GN=/uncomment/and/set/path/if/you/haz
export RUSTC_OPT_LEVEL=2
</pre>
<b>Debug Configuration</b>
<pre>
export CC=/usr/bin/gcc
export CXX=/usr/bin/g++

mk_add_options MOZ_MAKE_FLAGS="-j24"
ac_add_options --enable-application=browser
ac_add_options --enable-optimize="-Og -mcpu=power9"
ac_add_options --enable-debug
ac_add_options --disable-release
ac_add_options --enable-linker=bfd

#export GN=/uncomment/and/set/path/if/you/haz
export RUSTC_OPT_LEVEL=0
</pre>
</div>
</div>
<div class='post-footer'>
<div class='post-footer-line post-footer-line-1'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-footer-1-5134711199166894454' class='sharing' data-title='Firefox 81 on POWER'>
<button aria-controls='sharing-popup-Blog1-footer-1-5134711199166894454' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-footer-1-5134711199166894454' role='button'>
Share
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-footer-1-5134711199166894454' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=facebook' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=twitter' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=pinterest' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=1196390459016343329&postID=5134711199166894454&target=email' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.talospace.com/2020/09/firefox-81-on-power.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
<span class='byline'>
<a class='flat-button' href='https://www.blogger.com/email-post.g?blogID=1196390459016343329&postID=5134711199166894454'>Email Post</a>
</span>
</div>
</div>
</div>
</div>
<section class='comments embed' data-num-comments='0' id='comments'>
<a name='comments'></a>
<h3 class='title'>Comments</h3>
<div id='Blog1_comments-block-wrapper'>
</div>
<div class='footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<h4 id='comment-post-message'>Post a Comment</h4>
<p>Comments are subject to moderation. Be nice.</p>
<a href='https://www.blogger.com/comment-iframe.g?blogID=1196390459016343329&postID=5134711199166894454&skin=soho' id='comment-editor-src'></a>
<iframe allowtransparency='allowtransparency' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='410px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<script src='https://www.blogger.com/static/v1/jsbin/1068921344-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</div>
</section>
<div class='inline-ad'>
<ins class='adsbygoogle' data-ad-client='ca-pub-5054520162605658' data-ad-format='auto' data-ad-host='ca-host-pub-1556223355139109' data-analytics-uacct='' style='/* Done in css. */'></ins>
<script>
   (adsbygoogle = window.adsbygoogle || []).push({});
  </script>
</div>
</div>
</div>
</div>
</div>
</main>
</div>
<footer class='footer section' id='footer' name='Footer'><div class='widget Attribution' data-version='2' id='Attribution1'>
<div class='widget-content'>
<div class='blogger'>
<a href='https://www.blogger.com' rel='nofollow'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_post_blogger_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
Powered by Blogger
</a>
</div>
<div class='copyright'>Posts are the intellectual property of the original author and are under CC BY-SA 4.0.</div>
</div>
</div></footer>
</div>
</div>
<aside class='sidebar-container container sidebar-invisible' role='complementary'>
<div class='navigation'>
<svg class='svg-icon-24 touch-icon sidebar-back rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
<div class='section' id='sidebar' name='Sidebar'><div class='widget Label' data-version='2' id='Label1'>
<details class='collapsible extendable'>
<summary>
<div class='collapsible-title'>
<h3 class='title'>
Categories
</h3>
<svg class='svg-icon-24 chevron-down'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_more_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<svg class='svg-icon-24 chevron-up'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_less_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</summary>
<div class='widget-content list-label-widget-content'>
<div class='first-items'>
<ul>
<li><a class='label-name' href='https://www.talospace.com/search/label/Administrivia'>Administrivia<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Bare%20Metal'>Bare Metal<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/BSD'>BSD<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Distros'>Distros<span class='label-count'>50</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Firefox'>Firefox<span class='label-count'>25</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/First%20Person'>First Person<span class='label-count'>39</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Greatest%20Hits'>Greatest Hits<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Hacks'>Hacks<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Hardware'>Hardware<span class='label-count'>49</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/History'>History<span class='label-count'>4</span></a></li>
</ul>
</div>
<div class='remaining-items'>
<ul>
<li><a class='label-name' href='https://www.talospace.com/search/label/KVM'>KVM<span class='label-count'>10</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Microwatt'>Microwatt<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/News'>News<span class='label-count'>101</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Protips'>Protips<span class='label-count'>1</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Reviews'>Reviews<span class='label-count'>3</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Security'>Security<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Show%20Us%20Your%20Talos'>Show Us Your Talos<span class='label-count'>5</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Software'>Software<span class='label-count'>11</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/Wall%20of%20Shame%20Dept.'>Wall of Shame Dept.<span class='label-count'>5</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/WTF%20Dept.'>WTF Dept.<span class='label-count'>2</span></a></li>
<li><a class='label-name' href='https://www.talospace.com/search/label/YourHeadAsplode'>YourHeadAsplode<span class='label-count'>1</span></a></li>
</ul>
</div>
<span class='show-more flat-button'>Show more</span>
<span class='show-less hidden flat-button'>Show less</span>
</div>
</details>
</div><div class='widget BlogArchive' data-version='2' id='BlogArchive1'>
<details class='collapsible extendable'>
<summary>
<div class='collapsible-title'>
<h3 class='title'>
Past Posts
</h3>
<svg class='svg-icon-24 chevron-down'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_more_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<svg class='svg-icon-24 chevron-up'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_expand_less_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</summary>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive1_ArchiveList'>
<div class='first-items'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/'>
2020
<span class='post-count'>52</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/09/'>
September
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='posts hierarchy'>
<li>
<a href='https://www.talospace.com/2020/09/firefox-81-on-power.html'>Firefox 81 on POWER</a>
</li>
<li>
<a href='https://www.talospace.com/2020/09/the-first-production-risc-v-workstation.html'>The first production RISC-V workstation?</a>
</li>
<li>
<a href='https://www.talospace.com/2020/09/moar-openpower-cores-plz.html'>Moar OpenPOWER cores plz</a>
</li>
<li>
<a href='https://www.talospace.com/2020/09/ibm-open-sources-powerai-as-opence.html'>IBM open-sources PowerAI as OpenCE</a>
</li>
<li>
<a href='https://www.talospace.com/2020/09/microwatt-floats.html'>Microwatt floats</a>
</li>
</ul>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/08/'>
August
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/07/'>
July
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/06/'>
June
<span class='post-count'>9</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/05/'>
May
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/04/'>
April
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/03/'>
March
<span class='post-count'>4</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/02/'>
February
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2020/01/'>
January
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
</ul>
</div>
<div class='remaining-items'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/'>
2019
<span class='post-count'>82</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/12/'>
December
<span class='post-count'>3</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/11/'>
November
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/10/'>
October
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/09/'>
September
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/08/'>
August
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/07/'>
July
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/06/'>
June
<span class='post-count'>7</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/05/'>
May
<span class='post-count'>10</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/04/'>
April
<span class='post-count'>5</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/03/'>
March
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/02/'>
February
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2019/01/'>
January
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/'>
2018
<span class='post-count'>50</span>
</a>
</div>
<div class='hierarchy-content'>
<ul class='hierarchy'>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/12/'>
December
<span class='post-count'>9</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/11/'>
November
<span class='post-count'>6</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/10/'>
October
<span class='post-count'>10</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/09/'>
September
<span class='post-count'>8</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/08/'>
August
<span class='post-count'>15</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
<li class='archivedate'>
<div class='hierarchy-title'>
<a class='post-count-link' href='https://www.talospace.com/2018/07/'>
July
<span class='post-count'>2</span>
</a>
</div>
<div class='hierarchy-content'>
</div>
</li>
</ul>
</div>
</li>
</ul>
</div>
<span class='show-more flat-button'>Show more</span>
<span class='show-less hidden flat-button'>Show less</span>
</div>
</div>
</div>
</details>
</div><div class='widget HTML' data-version='2' id='HTML1'>
<h3 class='title'>
About Talospace
</h3>
<div class='widget-content'>
Talospace is a blog and news site <a href="/2018/07/welcome-to-talospace.html">primarily focusing</a> on OpenPOWER and the Raptor Talos series of computers along with modern Power ISA and historical PowerPC topics generally. Talospace is sponsored by <a href="https://www.floodgap.com/">Floodgap Systems</a>.
<p>
All articles remain the intellectual property of the original authors, and are distributable under Creative Commons CC BY-SA 4.0. Comments posted on articles are subject to moderation, and may be removed if spammy, unsolicited commercial advertising or otherwise abusive to authors or community members, in the administration's sole judgment.
<p>
Interested in writing for Talospace? Here's our <a href="/2018/07/write-for-talospace.html">author guidelines</a>.
<p>
Talospace collects no personally identifiable information from its members itself. Advertising proceeds are strictly used to support the domain name and other costs of hosting Floodgap resources.
<p>
OpenPOWER&trade; is a trademark of the <a href="https://openpowerfoundation.org/">OpenPOWER Foundation</a>. Talos&trade;, Blackbird&trade; and Condor&trade; are trademarks of <a href="https://www.raptorcs.com/">Raptor Computing Systems</a> LLC. Neither Raptor CS LLC nor the OpenPOWER Foundation has any corporate connection to this blog nor endorses or supports it.
<p>
Editorial inquiries may be sent to <tt>talospace at floodgap dawt com</tt>.</p></p></p></p></p>
</div>
</div>
</div>
</aside>
<script type="text/javascript" src="https://resources.blogblog.com/blogblog/data/res/1813830547-fancy_compiled.js" async="true"></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/1783702637-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>